fixed - Importing text for Reading Tool does not seem to work for Vietnamese

Posts3Likes3Joined15/12/2020LocationBR
Native
Portuguese
Learning Chinese - Mandarin, English, Indonesian, Japanese, Korean, Russian, Vietnamese

I don't know if this is a known issue, but importing text in Vietnamese to use with the reading tool does not seem to work. I tried importing the captions from a youtube video and the resulting text was all garbled, with few words recognized as words (the rest a mass of text without spaces). I thought it might be some issue with the importer so I imported a passage by copying the text (lyrics to a song) and the result is the same (so the importer worked). Also, the passages I create using Vietnamese as language seem to disappear from any list (there are no passages listed in "my passages" in Vietnamese). 


I will try creating it again: https://oplingo.com/reading/12554/read


And I'm attaching a screenshot to show how it gets if the passage can't be accessed. 



The original video is at MIN - ‘TRÊN TÌNH BẠN DƯỚI TÌNH YÊU’ OFFICIAL MUSIC VIDEO - YouTube

Edited 
1
#1
Posts1427Likes970Joined18/3/2018LocationBellingham / US
Native
English
Learning Portuguese
Other Chinese - Mandarin, French, Japanese, Korean, Russian, Spanish, Swahili, Tagalog, Thai

Hi tautologico,

Sorry for the problems with Vietnamese. I was able to get it to work here. Could you try it again please, just to make sure? If it fails, please let me know your browser/os/device and we will try to reproduce it. (edit - I just looked at your screen shot, and I wonder if my passage is incorrect; I don't speak Vietnamese)

I'm reading the Malazan Book of the Fallen.

Edited 
0
#2
Posts1427Likes970Joined18/3/2018LocationBellingham / US
Native
English
Learning Portuguese
Other Chinese - Mandarin, French, Japanese, Korean, Russian, Spanish, Swahili, Tagalog, Thai

It looks like we've lost the spacing between words. I have written a ticket.

I'm reading the Malazan Book of the Fallen.

Edited 
0
#3
Posts3Likes3Joined15/12/2020LocationBR
Native
Portuguese
Learning Chinese - Mandarin, English, Indonesian, Japanese, Korean, Russian, Vietnamese

Yeah I think the main issue may be caused by the importer merging most of the words together. I don't know if it happens because Vietnamese text uses a lot of unicode combining characters for the tone marks, usually the vowel is a single character or code point and then there's another character that is the tone mark that is combined with the previous character, so ầ (usually displayed as a single "character"/grapheme) is â + `.

Edited 
1
#4
Posts42Likes25Joined18/3/2018LocationGB
Native
French
Other English

A ton of the Vietnamese words were marked as ignored, I've reset them so now they'll be treated like words. This should be fixed but if this shows up again on new passages just comment here, if it were to show up I'd expect it to start with just the odd word here and there now though. (New words to the system)

Posted 
0
#5
Posts3Likes3Joined15/12/2020LocationBR
Native
Portuguese
Learning Chinese - Mandarin, English, Indonesian, Japanese, Korean, Russian, Vietnamese

Yeah it seems to work now, and there are spaces between words. I'll test adding more passages. 

Posted 
1
#6
    Feedback